Connectivity Issues
Incident Report for 4Schools
Postmortem

We discovered that a hosting provider updated an internal network address for a critical database server. Normally this is only expected during a maintenance window, but today the address changed right in the middle of the day. :-(

We have updated our application configurations to resume normal operations, and will be evaluating how these internal connections are managed so we don't trip over this kind of change next time.

Posted Jan 06, 2020 - 15:32 CST

Resolved
Services remain stable and the fix that we have put in place is expected to eliminate this issue moving forward. Thank you for your patience while we worked to identify and resolve the issue.
Posted Jan 06, 2020 - 15:20 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2020 - 14:29 CST
Update
At this time, we have identified the issue and put a fix into place to resolve the issues experienced. We apologize for the difficulties experienced and are now monitoring services to make sure that things remain stable.
Posted Jan 06, 2020 - 14:28 CST
Update
We're continuing to work on the issues being experienced and will provide more updates as we have information to share. Sorry for the difficulties. We're working hard to bring services back online.
Posted Jan 06, 2020 - 14:02 CST
Investigating
We are currently investigating an issue that is affecting the ability to login to the 4Schools applications including editing CMS4Schools websites.
Posted Jan 06, 2020 - 13:33 CST
This incident affected: WebOffice4Schools (Application, Database), myQuickReg (Application, Database), Calendar4Schools (Application, Database), and 4Schools (Application, Database).