Widespread Internet issues affecting 4Schools products

Incident Report for 4Schools

Resolved

Services are returning to normal. Cloudflare is tracking this issue with their network at https://new.cloudflarestatus.com/incidents/v3yl7jqmqj51
Posted Jun 22, 2026 - 10:03 CDT

Identified

Cloudflare has identified their service as the source of this problem and are implementing a fix.
Posted Jun 22, 2026 - 09:49 CDT

Investigating

We are currently investigating this issue.
Posted Jun 22, 2026 - 09:08 CDT
This incident affected: CMS4Schools (Application) and 4Schools (Application).