SEEDS Unable to accept student detail data
Incident Report for 4Schools
Postmortem

What happened to SEEDS this morning?

Today, SEEDS users discovered that some of the buttons and dropdown menus did not work on certain screens. Screens or forms would load, but when it came time to save the changes on those forms or select certain items, nothing would happen. Additionally, the user's web browser activity indicator would continuously spin on the SEEDS tab.

What caused this problem?

Some of the interactive parts of SEEDS are created using Javascript. Some of the components of Javascript are dynamically generated as data is added to SEEDS. These files are not generated frequently - maybe once a day or once a week. Once generated, they are served to your browser to make items and data magically appear as you navigate forms.
One of those files was updated recently. And the process responsible to update the file ran twice simultaneously. So instead of nice, clean Javascript, it contained two copies of the same file interspersed throughout the file. It was unreadable. We were able to resolve the problem by cleanly generating a new Javascript file.
Because this file doesn’t change often, it also gets cached for a long time in your web browser. So, even though the problem was fixed on the server, some of our users were still continuing to experience this problem.

I’m still seeing this problem in SEEDS. What can I do?

You can force your browser to grab a new copy of SEEDS files by clearing SEEDS out of your cache. In chrome:

  1. Copy this URL: chrome://settings/cookies/detail?site=seeds.4schools.net
  2. And paste it into Chrome’s URL bar. It will show you all the local data SEEDS stores in your browser
  3. Click “Remove All”

Next time you log in to SEEDS, you should have fresh, working copies of the SEEDs program files, and the problem should be resolved.If you use a different web browser other than Chrome, please contact our support team and we can provide directions tailored to your web browser.

Posted Oct 14, 2021 - 12:54 CDT

Resolved
We can confirm that the issue is resolved on the server and users who have followed the process to reload their SEEDS browser session have been able to see SEEDS screens working correctly again. Thank you for your patience as we worked through this issue.

If you are still experiencing difficulties after clearing your browser session, our customer support team is eager to help.
Posted Oct 14, 2021 - 09:54 CDT
Update
We have heard from some users that they are still seeing some broken buttons and menu items in SEEDS. If you are still experiencing this issue, please follow these steps:

1. Log out of SEEDS
2. Fully close your web browser
3. Re-open your web browser
4. Log back into SEEDS.

This should cause your browser to fetch the latest version of SEEDS program files, including the one that was fixed on the server at 9:00.
Posted Oct 14, 2021 - 09:19 CDT
Monitoring
An internal process was identified which caused an error while generating the graphical portion of SEEDS. Our team swiftly corrected the issue, and has verified that the broken buttons are now working. We will continue testing for User Interface problems over the next 15 minutes or so before considering this issue fully resolved, but we expect the issue has been fixed.
Posted Oct 14, 2021 - 09:05 CDT
Investigating
SEEDS is currently experiencing a problem where some buttons on the Student Detail view are not functioning. This issue is preventing users from submitting student detail data. We are investigating this issue now.
Posted Oct 14, 2021 - 08:35 CDT
This incident affected: SEEDS4Schools (Application).