Touch & Touch+ App Repeat Notifications (Posts)
Incident Report for 4Schools
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 14:56 CDT
Investigating
On Wednesday, 8/16/23, Touch App users may experience a repeat notification from a previous post. We apologize for this inconvenience and are working to resolve this issue promptly.
Posted Aug 16, 2023 - 09:45 CDT
This incident affected: CMS4Schools (CMS4Schools Touch / Touch+ Dashboard, CMS4Schools Touch Push Notifications).