What happened: Overnight on Sunday, April 5, a routine database server upgrade was performed. A component of CMS4Schools which processes content updates was affected and silently failed. As a result, a backlog of updates accumulated until the issue was fixed this morning. Content updates that were sent during this period have now been published, and new content should appear quickly as normal.
We are filling the gap in monitoring to detect this type of issue, and are implementing a more robust reconnection mechanism to prevent this problem from occurring in the future.
Posted Apr 06, 2026 - 11:35 CDT
Monitoring
A fix has been implemented, resolving the issue with delays. We are monitoring performance and collecting data to detect and prevent this issue from happening again.
Posted Apr 06, 2026 - 10:06 CDT
Investigating
Messages and publication of some new content on CMS4Schools are currently delayed due to a technical issue. We are currently investigating.
Posted Apr 06, 2026 - 09:30 CDT
This incident affected: CMS4Schools (Application, CMS4Schools Mass Notifications).