IEP4Schools loading slowly or unreliably

Incident Report for 4Schools

Monitoring

While triaging this issue, our team discovered that there may be network issues upstream from 4Schools services affecting large service providers. During our investigation, performance across these providers and 4Schools services suddenly returned to normal. We are keeping a close eye on Internet conditions and will resume investigating if this slowdown returns.
Posted Jun 02, 2026 - 09:21 CDT

Investigating

We are currently investigating this issue.
Posted Jun 02, 2026 - 08:54 CDT
This incident affects: IEP4Schools (Application).