SEEDS is glitchy this morning
Incident Report for 4Schools
Resolved
Things are better now! Our developers have spotted the problem with the update, rolled back the changes, and are putting safeguards in place so that, much like Superman, the sequel will be better than the original attempt.

If you are still experiencing glitches this morning, please try clearing SEEDS cache in your web browser. If SEEDS is still misbehaving, please contact your SEEDS support team for help.
Posted Oct 04, 2023 - 10:43 CDT
Investigating
An update to SEEDS didn't go as planned, and we're seeing some problems: Some menus, buttons, and forms that don't behave like they should. Student data is safe, but the SEEDS application is difficult to use right now. Our developers are actively on a fix.
Posted Oct 04, 2023 - 09:27 CDT
This incident affected: SEEDS4Schools (Application).